myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns
» Datenschutzerklärung
» Impressum

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » Entwicklungs- und Laufzeitumgebung (Infrastruktur) » [erledigt] Verweise zu NuGet Paketen passen nicht
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

[erledigt] Verweise zu NuGet Paketen passen nicht

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW


Christoph1972 ist offline

[erledigt] Verweise zu NuGet Paketen passen nicht

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

[EDIT]
Ich habe den Titel angepasst


Hallo zusammen,

wenn ich meine Git Repositories clone, fehlen die Pfade zu den referenzierten Bibliotheken, wie z.B. System, EntityFramework usw. Selbst wenn ich Referenzen entferne und manuell neu setze fehlt der Pfad zu der DLL. Auch nach einem Restore der NuGet Pakete fehlen die Pfade. Lediglich die Referenzen innerhalb der Solution sind vorhanden.

Kann mir jemand sagen was hier schiefläuft?

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von Christoph1972 am 03.06.2019 06:03.

22.05.2019 11:48 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 12.740
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Framework Dependencies werden niemals via Pfad angegeben.
NuGet Dependendies erfolgen ausschließlich die die Paketangabe.

Eigene Referenzen müssen Teil des Projekts seins; sonst sieht sie git schließlich gar nicht (darauf achten, dass sie nicht via gitignore erfasst werden).
Besser-> auch hier NuGet verwenden.

Daher die Rückfrage: warum referenzierst Du via Pfadangabe NuGet Pakete?
Hört sich danach an, dass Du das grundlegend nicht so machst, wie man es tun sollte ;)
22.05.2019 12:00 Beiträge des Benutzers | zu Buddylist hinzufügen
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW

Themenstarter Thema begonnen von Christoph1972

Christoph1972 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo Abt,

vielen Dank schon mal!

Ich habe nicht via Pfadangabe referenziert, mir war nur aufgefallen das die Pfade jetzt leer sind.

NuGet Pakete habe ich ganz simple installiert und damit gearbeitet. Referenzen auf .Net Komponenten habe ich per „Add Reference“ hinzugefügt.

Ich habe gerade noch mal ein Clone von einem Projekt erstellt und da fehlen alle Referenzen, außer die, die zum Projekt gehören.

Die Referenzen neu setzen funktioniert nicht, auch so das Restore der NuGet Pakete.

Zum Test habe ich Referenzen hinzugefügt, die ich nicht brauche, auch diese werden nicht übernommen. Alle Referenzen sind mit einem gelben Dreieck gekennzeichnet.

Seltsam…..
22.05.2019 12:44 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 12.740
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Christoph1972:
.Net Komponenten habe ich per „Add Reference“ hinzugefügt.

Was sind .NET Komponenten? verwundert

Zitat von Christoph1972:
Ich habe gerade noch mal ein Clone von einem Projekt erstellt und da fehlen alle Referenzen, außer die, die zum Projekt gehören.
Die Referenzen neu setzen funktioniert nicht, auch so das Restore der NuGet Pakete.

Ich hab nicht den Hauch einer Ahnung, was Du ausdrücken willst.

Weder Pakete noch Framework Referenzen sollten in Form von Dateien in der Quellcode-Verwaltung landen (SCCM Basics).
Bei einem Pull muss immer ein Restore erfolgen (egal ob in .NET (NuGet), Angular (NPM), Java (Maven) und all die anderen Paketmanager).
22.05.2019 12:48 Beiträge des Benutzers | zu Buddylist hinzufügen
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW

Themenstarter Thema begonnen von Christoph1972

Christoph1972 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Abt:
Was sind .NET Komponenten? :baby:

Damit meine ich z.B. Sytem, Sytem.XML usw.

Zitat von Abt:
Ich hab nicht den Hauch einer Ahnung, was Du ausdrücken willst.

Das ich versucht habe die Referenzen manuell neu zu setzen, diese aber auch nicht übernommen werden.

Zitat von Abt:
Bei einem Pull muss immer ein Restore erfolgen.

Das habe ich ja gemacht, funktioniert aber leider nicht. Die Referenzen auf die Pakete sind gelb gekennzeichnet und bleiben es auch, mit der Fehlermeldung, dass die referenzierte Komponente nicht gefunden werden kann.
22.05.2019 13:18 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 12.740
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Christoph1972:
Damit meine ich z.B. Sytem, Sytem.XML usw.

Das sind Framework Assemblies. Es gibt keine ".NET Komponenten" in dieser Hinsicht.

Zitat von Christoph1972:
Das ich versucht habe die Referenzen manuell neu zu setzen, diese aber auch nicht übernommen werden.

Was heisst "übernommen"? Es ist leider schwer Dir zu folgen.

Entweder die Referenz ist nach dem "Add" in der Liste von Visual Studio - oder nicht.
Framework Assemblies werden überhaupt nicht mit einem Pfad referenziert, sondern technisch mit einem Include.
<Reference Include="System.Xml.Linq" />
Dahingehend ist das die Registrierung im GAC - völlig egal wo dieser auf System B oder C .. liegt.

Anders das Referenzieren auf Dateiebene.
Referenzen via "Browse" müssen auf jedem Rechner exakt gleich gelegen sein - und teil des Git Repositories sein; ansonsten fehlen diese natürlich bei einem Pull - und das quittiert VS mit gelben Dreiecken.
Das spart man sich aber mit NuGet Paketen.

Hat aber alles prinzipiell nichts mit Git zutun; sondern mit den Basics wie man Abhängigkeiten organisiert.
22.05.2019 13:40 Beiträge des Benutzers | zu Buddylist hinzufügen
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW

Themenstarter Thema begonnen von Christoph1972

Christoph1972 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Wie auch immer, ich habe definitiv ein Problem mit einigen meiner Projekte.

Ich hatte noch die Idee, alle NuGet Pakete zu deinstallieren und es mit einer Neuinstallation zu versuchen, dabei habe ich festgestellt, dass sich die Pakete nicht deinstallieren lassen.

Wenn ich ein kleines Testprojekt mit NuGet Paketen anlege und pushe, dann clone, funktioniert alles wie erwartet.
22.05.2019 13:51 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 12.740
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Dann scheinste Dein Projekt/Solution evtl. einfach durch komische Dinge zerschossen zu haben.
22.05.2019 13:59 Beiträge des Benutzers | zu Buddylist hinzufügen
WarLorD_XaN WarLorD_XaN ist männlich
myCSharp.de-Mitglied

Dabei seit: 25.10.2006
Beiträge: 91
Entwicklungsumgebung: Visual Studio
Herkunft: Austria


WarLorD_XaN ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

Pfadangaben von Nuget Paketen werden in der *.csproj Datei relativ gespeichert. Und zwar relativ im Bezug auf die Solution Datei.

Ich hatte da schon mal Probleme im Zusammenhang mit git submodulen.

Eventuell liegts an was ähnlichem...

sg,
xan
22.05.2019 15:26 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW

Themenstarter Thema begonnen von Christoph1972

Christoph1972 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo zusammen,

einige Pfade zu den NuGet Paketen in den *.csproj Files haben nicht gepasst haben. Die Pfade der „Unter“-Projekte haben auf das Startprojekt gezeigt.

Folgende Verzeichnisstruktur kommt bei mir zum Einsatz:

Projektmappe
UI
--ProjektUI1 (Startprojekt)
--ProjektUI2
LL
--ProjektLL1
--ProjektLL2
DAL
--ProjektDAL1
--ProjektDAL2
Shared
--Shared1
--Shared2

Sämtliche Projekte, bei denen ich mit dieser Struktur arbeite, sind davon betroffen. Interessant ist, dass die Originalversion im Working Directory funktioniert, auch das Updaten der Pakete geht. Bei einem Testprojekt konnte ich das Problem nicht nachstellen, ich werde das eine Weile beobachten. Zum Glück kann man das Problem gut beheben!

Vielen Dank für die Unterstützung!
24.05.2019 08:53 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
p!lle
myCSharp.de-Mitglied

avatar-3556.jpg


Dabei seit: 22.02.2007
Beiträge: 987
Entwicklungsumgebung: Visual Studio (Community) 2017


p!lle ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Kannst du die kaputte Solution zur Verfügung stellen?
Gerne auch abgespeckt, sodass nur 3 Projekte oder so in der Solution sind. fröhlich
29.05.2019 09:42 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Christoph1972 Christoph1972 ist männlich
myCSharp.de-Mitglied

avatar-2726.jpg


Dabei seit: 19.09.2008
Beiträge: 210
Entwicklungsumgebung: VS2015 Pro
Herkunft: NRW

Themenstarter Thema begonnen von Christoph1972

Christoph1972 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von p!lle:
Kannst du die kaputte Solution zur Verfügung stellen?

Das ist leider nicht möglich.
03.06.2019 06:01 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum Der Startbeitrag ist älter als ein Monat.
Antwort erstellen


© Copyright 2003-2019 myCSharp.de-Team | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 26.06.2019 22:34