myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Gemeinschaft » Smalltalk » Session / Cookies Handling des Forums meldet mich alle paar Stunden ab
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

Session / Cookies Handling des Forums meldet mich alle paar Stunden ab

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
inflames2k inflames2k ist männlich
myCSharp.de-Poweruser/ Experte

avatar-3407.gif


Dabei seit: 03.01.2010
Beiträge: 2.239
Entwicklungsumgebung: Visual Studio 2010 Express


inflames2k ist offline

Session / Cookies Handling des Forums meldet mich alle paar Stunden ab

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

mir ist das jetzt schon mehrfach aufgefallen. Wurde in letzter Zeit was am Session Handling des Forums geändert?

Frage deshalb, weil ich bisher dauerhaft angemeldet war und neuerdings alle paar Stunden abgemeldet bin. Ein wenig lästig ist das schon.
26.09.2019 13:53 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Jamikus Jamikus ist männlich
myCSharp.de-Mitglied

Dabei seit: 15.11.2012
Beiträge: 232
Entwicklungsumgebung: MS Visual
Herkunft: Oberhausen (NRW)


Jamikus ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ich kann dies nicht bestätigen.
Bin mit den Firefox (69.0.1 (64-Bit)), immernoch wie gewohnt dauerhaft angemeldet.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Jamikus am 26.09.2019 14:01.

26.09.2019 14:01 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
inflames2k inflames2k ist männlich
myCSharp.de-Poweruser/ Experte

avatar-3407.gif


Dabei seit: 03.01.2010
Beiträge: 2.239
Entwicklungsumgebung: Visual Studio 2010 Express

Themenstarter Thema begonnen von inflames2k

inflames2k ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Surfe mit der gleichen Version auf arbeit. Und da tritt das Phänomen auf.

Naja muss ich mal weiter beobachten.
26.09.2019 14:35 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hi,

also umgestellt wurde nichts - und mir ist auch nichts aufgefallen (verwende Microsoft Edge Dev).
Bist auch der erste, der jetzt was dazu schreibt.

Unser Monitoring trackt aber keine persönlichen Session-Informationen, daher kann ich da leider auch keine Infos aus irgendwelchen Reports ziehen.
26.09.2019 14:54 Beiträge des Benutzers | zu Buddylist hinzufügen
Th69
myCSharp.de-Poweruser/ Experte

avatar-2578.jpg


Dabei seit: 01.04.2008
Beiträge: 3.590
Entwicklungsumgebung: Visual Studio 2015/17


Th69 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ist bei dir in den Einstellungen evtl. "Cookies und Website-Daten beim Beenden von Firefox löschen" gesetzt?
Oder passiert das, während Firefox läuft und du (nach einiger Zeit) wieder auf die Forumseite wechselst?
26.09.2019 14:55 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Spook Spook ist männlich
myCSharp.de-Mitglied

Dabei seit: 28.10.2008
Beiträge: 208
Entwicklungsumgebung: VS2019
Herkunft: Esslingen a.N.


Spook ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

mir ist dies heute auch zum ersten Mal aufgefallen.
Nach einem Neustart des Browsers ist der Login auch direkt weg.

Ich habe testhalber Cookies explizit für die Webseite erlaubt und das Löschen beim Beenden ist in den Einstellungen deaktiviert.

Habe ebenfalls FF 69.0.1 (64-Bit).

@Th69
Ja nach einiger Zeit, oder Neustart des Browsers

Edit:

In Edge geht es ohne Probleme.

Das Löschen aller Cookies im FF über STRG+SHIFT+DEL scheint das Problem, zumindest beim Browser Neustart, gelöst zu haben.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Spook am 26.09.2019 15:18.

26.09.2019 15:04 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Riecht jetzt erst mal für mich, dass es eher am Browser liegt statt am System.
Kann aber gut sein, dass es Changes im Browser gab, die ich jetzt nicht kenne, das Auswirkungen darauf hat.

Wenn da jemand Infos hat, gerne her damit.
26.09.2019 15:20 Beiträge des Benutzers | zu Buddylist hinzufügen
witte
myCSharp.de-Mitglied

Dabei seit: 03.09.2010
Beiträge: 866


witte ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Das Problem mit FF besteht schon seit mehreren Monaten, seit Umstellung auf Azure? Das läßt sich jedoch nicht nachvollziehen, manchmal ist der Login weg, nach Neustart FF loggt er sich wieder automatisch ein. In der letzten Zeit scheint es seltener geworden zu sein, vllt sind auch FF-plugins ein Problem.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von witte am 26.09.2019 16:45.

26.09.2019 16:45 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
lukasrad02 lukasrad02 ist männlich
myCSharp.de-Mitglied

Dabei seit: 02.06.2019
Beiträge: 4
Entwicklungsumgebung: VS 2017/2019 Community VS Code


lukasrad02 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ich habe genau das gleiche Problem: ich melde mich an, lese einige Beiträge und verlasse dann die Seite, ohne mich abzumelden. Wenn ich einige Zeit später (vllt 1h) wieder das Forum aufrufe (ohne den Browser zwischendrin geschlossen zu haben), bin ich wieder abgemeldet.
Wenn ich mich richtig erinnere, tritt das Problem bei mir auf, seitdem ich von verschiedenen Systemen/Geräten auf das Forum zugreife. Anfangs, als ich immer nur vom gleichen PC aus zugegriffen habe, wurde ich nicht abgemeldet.

Die jeweiligen genutzten Systeme sind:
1. Win10, aktuelle FF-Version (69.0.1, 64-bit)
2. Linux Mint, aktuelle FF-Version (69.0.1, 64-bit)

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von lukasrad02 am 26.09.2019 20:44.

26.09.2019 20:27 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von witte:
Das Problem mit FF besteht schon seit mehreren Monaten, seit Umstellung auf Azure?

Dass es am Hosting liegt mach ich mal ausschließen.
Wenn dem so wäre, wäre jeder betroffen.

Zitat von lukasrad02:
Anfangs, als ich immer nur vom gleichen PC aus zugegriffen habe, wurde ich nicht abgemeldet.

Die Forumsettings sind seit ca. 12 Jahren so, dass Du Dich nicht mit zwei Geräten zeitgleich anmelden kannst.
Ist leider so ein phpBB Ding.
26.09.2019 21:14 Beiträge des Benutzers | zu Buddylist hinzufügen
inflames2k inflames2k ist männlich
myCSharp.de-Poweruser/ Experte

avatar-3407.gif


Dabei seit: 03.01.2010
Beiträge: 2.239
Entwicklungsumgebung: Visual Studio 2010 Express

Themenstarter Thema begonnen von inflames2k

inflames2k ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ok, damit scheine ich ja doch nicht der einzige zu sein. Grundsätzlich tritt das Verhalten jedoch bei geöffnetem Browser auf.

Zeitlich kann ich es jedoch nicht mit der Azure Umstellung in Verbindung bringen. Das Verhalten tritt bei mir seit Mitte Juli auf, umgestellt wurde doch aber schon im Mai.

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von inflames2k am 27.09.2019 08:14.

27.09.2019 08:11 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Spook Spook ist männlich
myCSharp.de-Mitglied

Dabei seit: 28.10.2008
Beiträge: 208
Entwicklungsumgebung: VS2019
Herkunft: Esslingen a.N.


Spook ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Das Löschen des Cookie Caches scheint das Problem bei mir gelöst zu haben. Bin seit gestern Nachmittag immer noch eingeloggt und bleibe es anscheinend auch nach mehreren Pausen und Reboot des Rechners.
27.09.2019 10:26 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
lukasrad02 lukasrad02 ist männlich
myCSharp.de-Mitglied

Dabei seit: 02.06.2019
Beiträge: 4
Entwicklungsumgebung: VS 2017/2019 Community VS Code


lukasrad02 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Abt:
Die Forumsettings sind seit ca. 12 Jahren so, dass Du Dich nicht mit zwei Geräten zeitgleich anmelden kannst.
Ist leider so ein phpBB Ding.

Ich habe mich seit gut einer Woche nicht mehr über das WIndows-System angemeldet und fliege auf dem Linux-Rechner trotzdem immer noch raus.

Zitat von Spook:
Das Löschen des Cookie Caches scheint das Problem bei mir gelöst zu haben.

Das probiere ich mal aus und melde mich, ob es etwas gebracht hat.
27.09.2019 19:11 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
lukasrad02 lukasrad02 ist männlich
myCSharp.de-Mitglied

Dabei seit: 02.06.2019
Beiträge: 4
Entwicklungsumgebung: VS 2017/2019 Community VS Code


lukasrad02 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Nach dem Löschen aller Cookies für mycsharp.de funktioniert es bei mir nun auch wieder. Vielen Dank für den Tipp!
28.09.2019 12:21 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
inflames2k inflames2k ist männlich
myCSharp.de-Poweruser/ Experte

avatar-3407.gif


Dabei seit: 03.01.2010
Beiträge: 2.239
Entwicklungsumgebung: Visual Studio 2010 Express

Themenstarter Thema begonnen von inflames2k

inflames2k ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Fürs erste bestätige ich auch mal die Lösung den Cookie-Cache zu löschen. Für eine tatsächlich Aussagekräftige Bestätigung warte ich lieber noch ein paar Tage. Der Logout fand ja auch nicht jeden Tag statt bei mir.
30.09.2019 07:57 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
herbivore
myCSharp.de-Poweruser/ Experte

avatar-2627.gif


Dabei seit: 11.01.2005
Beiträge: 49.474
Entwicklungsumgebung: csc/nmake (nothing is faster)
Herkunft: Berlin


herbivore ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo zusammen,

wie schon weiter oben angeklungen, wird man auf dem bestehenden Gerät/Browser ausgeloggt, wenn man sich auf einem anderen Gerät/Browser einloggt. Das liegt daran, dass beim Einloggen eine long-time session id generiert, im Cookie (eben genau des aktuell verwendeten Browsers) gespeichert und ab da zur Authentifizierung des Benutzers verwendet wird. Diese ID ist prinzipiell unendlich lange gültig, aber mit einem neuen Einloggen wird eine neue ID generiert und dadurch verliert die bisherige ID ihre Gültigkeit.

Ich will nun wahrlich keine Panik verbreiten und halte die folgende Möglichkeit auch für sehr, sehr unwahrscheinlich. Trotzdem schreib ich es mal zur Vollständigkeit.

Wer auch immer sich wo neu einloggt, bewirkt also, dass der bisherige Login ungültig wird. "Wer auch immer" muss man nicht unbedingt selber sein. Wenn sich also jemand anderes im Besitz der Zugangsdaten befindet und sich damit einloggt, würde das ebenfalls bewirken, dass man selber ausgeloggt ist.

Wie gesagt, sehr unwahrscheinlich. Aber es schadet auch nicht, (vorsorglich) mal das Passwort zu ändern. Vor allem, wenn das aktuelle Passwort kurz oder aus anderen Gründen unsicher ist.

herbivore

PS: Aus dem zur Funktionsweise Gesagten ergibt sich eine prinzipielle, aber eher fummelige Möglichkeit, auf zwei (oder sogar mehr) Geräten dauerhaft eingeloggt zu bleiben, nämlich indem man sich auf einem Gerät/Browser einloggt und dann den resultierenden Cookie auf dem anderen Gerät/Browser passend implantiert. Als Cookies noch einzelne Textdateien waren, ging das sogar praktisch relativ einfach, aber seit Cookies in (lokalen) Datenbanken gespeichert werden, ist es umständlicher geworden.
02.10.2019 13:13 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
inflames2k inflames2k ist männlich
myCSharp.de-Poweruser/ Experte

avatar-3407.gif


Dabei seit: 03.01.2010
Beiträge: 2.239
Entwicklungsumgebung: Visual Studio 2010 Express

Themenstarter Thema begonnen von inflames2k

inflames2k ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo herbivore,

danke für den Beitrag. - Ich denke aber dass der Ablauf hier so nicht war. Wie wahrscheinlich wäre denn wohl dass die Zugangsdaten mehrerer Forenmitglieder im Umlauf wären?

Nichts desto trotz sollte man das im Hinterkopf behalten.

PS: Da ich nun seit Löschen des Cookie Caches nicht mehr ausgeloggt wurde, neige ich dazu das als Lösung voll und ganz zu bestätigen.
02.10.2019 16:52 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von inflames2k:
Wie wahrscheinlich wäre denn wohl dass die Zugangsdaten mehrerer Forenmitglieder im Umlauf wären?

Nahezu 0.

Aber wie wahrscheinlich ist es, dass es "plötzlich" am Forum (oder dessen Unterbau) liegt, wenn nicht mal eine Handvoll User betroffen sind? :-)

Nahezu 0. :-)


Der Information halber:
Wir arbeiten prinzipiell ja an einer neuen Forentechnik (das Produktivsystem ist seit Wochen hier aber unverändert), und hier funktioniert der Login anders.
Auch kann man über die Accountverwaltung zeitgemäß alle aktiven Sessions sehen (und eben verwalten).
02.10.2019 17:04 Beiträge des Benutzers | zu Buddylist hinzufügen
herbivore
myCSharp.de-Poweruser/ Experte

avatar-2627.gif


Dabei seit: 11.01.2005
Beiträge: 49.474
Entwicklungsumgebung: csc/nmake (nothing is faster)
Herkunft: Berlin


herbivore ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo inflames2k, hallo zusammen,

noch ein (hoffentlich!?) letztes Wort zu den Wahrscheinlichkeiten. Dass ich die Möglichkeit selbst für sehr, sehr unwahrscheinlich halte, hatte ich von Anfang an geschrieben.

Zitat:
Wie wahrscheinlich wäre denn wohl dass die Zugangsdaten mehrerer Forenmitglieder im Umlauf wären?

Dass mehrere Benutzer betroffen waren, war mir bewusst. Und auch dass die Wahrscheinlichkeit des zeitgleichen Auftreten mehrerer sehr unwahrscheinlicher Ereignisse *exorbitant* gering ist, quasi nahezu ausgeschlossen. Das gilt aber nur, wenn die Ereignisse *unabhängig* voneinander sind. Das wäre der Fall, wenn einzelne Zugangsdaten z.B. durch Unachtsamkeit im jeweiligen Bekanntenkreis bekannt und dann auch tatsächlich noch benutzt werden. Bei einem gezielten Angriff (den ich hier ausdrücklich betont *nicht* sehe), wäre diese Unabhängigkeit nicht gegeben. Dann bliebe die Wahrscheinlichkeit einfach nur sehr gering, würde aber nicht dadurch geringer, dass das Phänomen bei mehreren Personen auftritt. Ich glaub da nicht dran, hatte es - wie gesagt - nur der Vollständigkeit halber geschrieben. Auch das jetzt nur der Vollständigkeit halber.

Ich stimme mit deiner Vermutung über die Ursache überein und sehe das Problem als gelöst an.

herbivore
02.10.2019 18:29 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ich bin die Tage auf einen Beitrag im Chrome Feature Status gestoßen:  Cookies default to SameSite=Lax

Vermute, dass sich hier Firefox nicht so verhält, wie es andere Browser tun - wieso hab ich bislang nicht herausfinden können; sehr wohl aber dass Firefox offenbar auf vielen Seiten diese Symptome hat.
Hab nun auf dem Testsystem mal Lax-Settings hinterlegt und teste das die nächsten Tage.
23.10.2019 22:47 Beiträge des Benutzers | zu Buddylist hinzufügen
Frokuss
myCSharp.de-Mitglied

Dabei seit: 26.08.2015
Beiträge: 156


Frokuss ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Also, das löschen der Cookies hat bei mir zur Lösung verholfen. Ich wurde allerdings unmittelbar NACH dem login gesperrt und konnte weder einen neuen Post noch eine PM absetzen. Konnte also wirklich nichts machen...
Das ganze war mit dem FF 69.0.3 (64-Bit).

Gruß Frokuss
24.10.2019 12:29 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
p!lle
myCSharp.de-Mitglied

avatar-3556.jpg


Dabei seit: 22.02.2007
Beiträge: 1.032
Entwicklungsumgebung: Visual Studio (Community) 2019


p!lle ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Was heißt denn "gesperrt"?
Ich würde eher sagen: man wurde nicht eingeloggt.

Mir ist es vor ein paar Tagen auch aufgefallen:
- seit Wochen auf Arbeit im Forum angemeldet, alles gut
- vorgestern oder so dann zuhause eingeloggt: das Einloggen war nicht möglich, man wurde nie eingeloggt
- nach dem Löschen der Cookies ging es
- jetzt wieder auf Arbeit eingeloggt, ging sofort

Browser war immer der Firefox.
24.10.2019 12:39 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Frokuss
myCSharp.de-Mitglied

Dabei seit: 26.08.2015
Beiträge: 156


Frokuss ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von p!lle:
Was heißt denn "gesperrt"?
Ich würde eher sagen: man wurde nicht eingeloggt.

Naja, aber bei mir ist auf jeden Fall nach dem login die Seite gekommen, bei der auch der Link angezeigt wurde, wenn die automatische Weiterleitung nicht funktioniert... Ich war auch für sehr sehr sehr kurze Zeit eingelogt. Konnte auf "meinem Profil" sehen, was ich aktuell betrachte.

Aber wie gesagt, löschen der Cookies hat hier weitergeholfen.
Frokuss
24.10.2019 12:44 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Frokuss:
Ich wurde allerdings unmittelbar NACH dem login gesperrt und konnte weder einen neuen Post noch eine PM absetzen.

Dein Account wurde nicht "gesperrt"...
Wärst Du gesperrt, dann würdest Du eine entsprechende Meldung bekommen - und wir würden es auch als Admin sehen.
Kann Dir versichern: da wurde nichts gesperrt.

Zitat von p!lle:
Browser war immer der Firefox.

Ich konnte leider im Changelog von den Firefox Updates nichts finden, was auf irgendeine Sache hinweisen würde.
Nur die Sache mit SameSite konnte ich finden, was eine allgemeine Sache ist und eigentlich seit 9 Major Versionen in Firefox schon vorhanden ist.

Dass es nach dem Löschen plötzlich funktioniert scheint auch ein Firefox-Thema zu sein.
Mit den anderen Browsern gibt es ja offenbar nicht so ein Fehlverhalten.

Ich verwende aktuell den Firefox und bisher ist mir nichts aufgefallen.

Ich wäre sehr interessiert an einem Screenshot der aktuell vorhandenen Cookies bei jemanden, der Probleme damit hat (F12 Developer Tools -> "Storage Tab" -> Cookies).
 Kontakt zum Team
24.10.2019 13:26 Beiträge des Benutzers | zu Buddylist hinzufügen
T-Virus T-Virus ist männlich
myCSharp.de-Mitglied

Dabei seit: 17.04.2008
Beiträge: 1.503
Entwicklungsumgebung: Visual Studio, Codeblocks, Edi
Herkunft: Nordhausen, Nörten-Hardenberg


T-Virus ist offline Füge T-Virus Deiner Kontaktliste hinzu

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Bin nicht ganz sicher ob es der Diskussion hilft aber bei Chrome wird das Same site Cookie Verhalten in der Version 80 sogar zum Standard.

 Golem

Vielleicht hilft es euch weiter.

T-Virus

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von T-Virus am 25.10.2019 13:18.

25.10.2019 13:18 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

.. mit dem Unterschied dass Chrome (und auch die anderen, ausser IE) wohl das Lax-Verhalten  als Standard übernehmen wird und Firefox offenbar Strict.
Wobei es zum Firefox unterschiedliche Informationen gibt ( hier default auch Lax).
Ich glaube aber mittlerweile nicht mehr, dass das die Ursache für das Problem ist.
25.10.2019 14:26 Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Herzlichsten Dank an  Palladin007!
Er scheint das Problem identifiziert zu haben - und ich konnte dazu auch einen Bug in Firefox finden, der bereits in der Vergangenheit existiert hat und anscheinend mit der Version 69 erneut auftritt:

Firefox behandelt den Cookie Pfad nicht mehr wie in vorherigen Versionen, sodass das Forum nach dem Anmelden den Cookie zwar an den Browser schickt, Firefox diesen aber nicht richtig zuordnet und beim nächsten Request nicht mitschickt -> nicht mehr angemeldet.
 Firefox Bug Tracker: Default Cookie Path includes trailing slash

Wir schauen mal, ob wir hier überhaupt was auf der Forenseite ändern können.
Danke nochmal!
27.10.2019 19:01 Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.827
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Der Cookie wird nun auf den Root geschrieben.
Dadurch sollte es kein Trailing Slash Problem mehr geben.

Gerne Feedback :-)
29.10.2019 12:00 Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum Der Startbeitrag ist älter als 8 Monate.
Der letzte Beitrag ist älter als 7 Monate.
Antwort erstellen


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 03.06.2020 04:36